Back to overview
Degraded

Cryptocurrency Payments Not available

Jan 30 at 07:36pm CET

Updated
Feb 08 at 06:13pm CET

News from sellix:

Seizure of assets - update

The attorneys representing us are in the process of formally filing a motion for review with the aim of regaining possession of the assets subject to seizure.

We remain committed to protecting the company’s rights and interests and will provide further updates as necessary. Our current timeline for resolution is at most by the end of the month, though we are hopeful for a sooner outcome.

We want to reassure everyone that we can confirm the database has not been deleted—only stopped. The same applies to all of our servers. Additionally, all funds (outside of the non-custodial service, for which we have no control over) remain safe.

Thank you for your patience and support, we will continue to send updates here.

Updated
Feb 04 at 07:38pm CET

Still waiting for Sellix, We're going to add a temporary solution.

Updated
Jan 31 at 09:20pm CET

Sellix's Official statement on Operation Talent.

https://sellix.com

Updated
Jan 30 at 07:37pm CET

Sellix does not appear to have broken any laws, although they may have been indirectly associated with forums selling illegal products.

We will give you more information as soon as we have it.

https://hackread.com/operation-talent-fbi-seizes-nulled-to-cracked-to-sellix-io/

Created
Jan 30 at 07:36pm CET

Due to the FBI's seizure of Sellix's domains and machines, it is now impossible for us to accept cryptocurrency payments.